Subject: Recent OpenSSL dependency change
To: None <>
From: Martti Kuparinen <>
List: tech-pkg
Date: 11/13/2003 08:59:58

Is this "the right thing to do"? I have built-in OpenSSL but it's not used...

Should we fix the dependency so that fixed implementations are
accepted even if the appear to be older than 0.9.6l? Or should
we get the new OpenSSL into netbsd-1-6 right after 1.6.2 (I assume
it's too late for 1.6.2)?


ROOT p4:/usr/pkgsrc/mail/imap-uw> uname -srm
NetBSD 1.6.2_RC1 i386

ROOT p4:/usr/pkgsrc/mail/imap-uw> openssl version
OpenSSL 0.9.6g 9 Aug 2002

ROOT p4:/usr/pkgsrc/mail/imap-uw> make clean clean-depends
===> Cleaning for imap-uw-2002.5nb2
===> Cleaning for perl-5.6.1nb9
===> Cleaning for libtool-base-1.4.20010614nb16
===> Cleaning for openssl-0.9.6l