Subject: pkgsrc/fonts/Xft2 depending Xrender/render
To: None <>
From: Brian A. Seklecki <>
List: tech-pkg
Date: 11/09/2003 17:17:39
I noticed that Xft2 depends on two small X11 packages, x11/Xrender and  
hence x11/render.  On NetBSD/i386, the files provided  by x11/render  
are already provided in xsrc at:


and are installed in:

/usr/X11R6/include/X11/extensions/* for pkgsrc/x11/Xrender, those files are also present by default  
yet we depend them anyway, hence we now have duplication of the render/ 
Xrender libraries and headers.

Perhaps this is to accomodate non-NetBSD platforms?  This this to  
provide the very latest revisions per some other dependancy? Shouldn't  
we have a NOT_FOR_PLATFORM= NetBSD-*-*

It just seems messy,