Subject: Re: libnids fails to build
To: Perry E. Metzger <>
From: None <>
List: tech-pkg
Date: 10/29/2003 19:26:20
On Wed, Oct 29, 2003 at 01:08:18PM -0500, Perry E. Metzger wrote:
> writes:
> > Ok, libnet was from pre-gcc3 userland, and contained an erroneous
> > header. It was the subject of 22822, and was committed since.
> > 
> > That issue raises a question though: should we bump for such
> > gcc3 fixes? I guess we should, when the error is in an exported
> > header such as here.
> Yes, and have the depending packages (like libnids) depend on the
> bumped version.

I don't think we have to bump revision of all dependencies: it only
affects building, not packaging or run-time. The only thing we need
to bump is the requirement in the file: then when you
build a dependency, it will rebuild libnet.

Am I missing something?

Quentin Garnier.