Subject: xscreensaver[-gnome] conflicts
To: None <>
From: Louis Guillaume <>
List: tech-pkg
Date: 10/20/2003 22:52:56
Hi again,

I've been running into this issue with xscreensaver and 
xscreensaver-gnome for quite some time now...

If xscreensaver is installed, and you try to install anything that has 
anything that wants xscreensaver-gnome there is a conflict...

=> Checksum OK for ee-0.3.12.tar.gz.
===> Extracting for ee-0.3.12nb6
===> Required installed package gnome1-dirs>=1.2: gnome1-dirs-1.2 found
===> Required installed package control-center>= 
control-center- found
===> Required package gnome-core>=1.4.2nb6: NOT found
===> Verifying package for ../../x11/gnome-core
===> Checking for vulnerabilities in gnome-core-1.4.2nb7
=> Checksum OK for gnome-core-1.4.2.tar.bz2.
===> Extracting for gnome-core-1.4.2nb7
===> Required installed package gnome1-dirs>=1.0: gnome1-dirs-1.2 found
===> Required package xscreensaver-gnome>=3.25nb1: NOT found
===> Verifying package for ../xscreensaver-gnome
===> Checking for vulnerabilities in xscreensaver-gnome-4.13
===> Installing for xscreensaver-gnome-4.13
===> xscreensaver-gnome-4.13 conflicts with installed package(s): 
xscreensaver-4.13  found.
*** They install the same files into the same place.
*** Please remove xscreensaver-4.13  first with pkg_delete(1).
*** Error code 1

... but we NEED xscreensaver for other desktop environments like kde, or 
xfce-desktop. The reverse also happens if xscreensaver-gnome is 
installed and  we try to install xscreensaver.

Can we make it so that either one of these packages will satisfy the 
need for the other?

And what's so special about the gnome variant anyway?

Perhaps there can be just one xscreensaver package that satisfies all.

Please let me know if I can help in any way. Thanks,