Subject: Re: MySQL will be updated
To: None <>
From: Robert Elz <kre@munnari.OZ.AU>
List: tech-pkg
Date: 10/06/2003 09:56:16
    Date:        Sun, 5 Oct 2003 20:24:45 +0100 (BST)
    From:        <>
    Message-ID:  <>

  | AFAIK MySQL 4.x still has one remaing problem on -current which is that
  | it's still not shutting down correctly.  This was a problem with 3.x and I
  | tried the same fix for 4.x, with no luck.  It's been a problem ever since
  | the package first hit pkgsrc-wip.

It's been a problem for longer than that - I sent in a PR with a mysql4
pkgsrc entry in it (an older one than is in pkgsrc-wip - much older)
ages ago, the "refuse to exit" problem was there as well.

What's more, that was on NetBSD 1.6 (or 1.6.1, I forget) using pth.

If the same problem exists on -current, then perhaps it isn't a NetBSD
or NetBSD threads problem at all (which is what I had assumed), but some
kind of generic MySQL 4 problem?


ps: if someone can find my old PR, it should be closed now, it is obsolete.
(Seems to be 19105).