Subject: default to teTeX2
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 09/24/2003 15:00:23
Has there been any discussion on defaulting to teTeX2?

A lot of packages depend on teTeX, when teTeX2 should be fine. But if not
already installed (via pkgsrc) uses old teTeX too.

Maybe we should start switching to something like:

DEPENDS+=       teTeX{,2}>=1.0.6:../../print/teTeX2

From looking at teTeX HOMEPAGE, I don't see reference to old (pre-2)
versions. The download site linked from the official webpage doesn't have
old (pre-2) versions.

I am using texmacs using newer teTeX2-2.0.2.

Also look at PR 21084
Some pkgs should depend on teTeX OR teTeX2 ...

   Jeremy C. Reed