Subject: Re: pkgsrc OS support
To: Soren Jacobsen <>
From: Jaromir Dolecek <>
List: tech-pkg
Date: 09/20/2003 11:10:49
Soren Jacobsen wrote:
> On 09/19 15:46, Aaron J. Grier wrote:
> > What OSes are officially supported by pkgsrc?
> > 
> > (IE am I wasting my time filing PRs for problems with pkgsrc and NetBSD
> > 1.4.3A?)
> If my memory serves me, pkgsrc is "supposed" to support the latest two
> releases and -current. But, then again, I have nothing to back that up
> with, and we make lots of exceptions in packages for non-NetBSD
> operating systems as it is, so it doesn't seem like adding quirks for
> NetBSD 1.4 systems is such a big deal. It does, however, encourage you
> to keep using that old system, and I don't think we want to do that ;)

1.4.x was EOLed for base system (no new patches are applied to 1.4
branch). It'd be less likely the changes could be committed - they
need to be tested before commit, and there are not many people
who have 1.4 still installed for pkgsrc testing.

Jaromir Dolecek <>  
-=- We should be mindful of the potential goal, but as the tantric    -=-
-=- Buddhist masters say, ``You may notice during meditation that you -=-
-=- sometimes levitate or glow.   Do not let this distract you.''     -=-