Subject: Re: pkg_install/libnbcompat on OpenBSD
To: None <>
From: Jun-ichiro itojun Hagino <>
List: tech-pkg
Date: 09/16/2003 06:32:06
> 	it seems that pkgtools/libnbcompat and libnbcompat included in
> 	pkgtools/pkg_install does not compile on OpenBSD 3.4/i386 (ELF),
> 	due to some differences in evaluating expanded __weak_alias().
> 	do we really need __weak_alias in libnbcompat?

	another thing i noticed when i tried pkgsrc on OpenBSD 3.4/i386:

	- OBJECT_FMT is not defined (where should it be defined?)
	- perl 5.8.0 exists in /usr/bin/perl, however, lang/perl5 do try to
	  build perl

	i'm not too familiar with pkgsrc-on-non-netbsd, so advise/help would be