Subject: Re: pkg_install/libnbcompat on OpenBSD
To: Jun-ichiro itojun Hagino <>
From: Johnny C. Lam <>
List: tech-pkg
Date: 09/15/2003 21:35:54
On Tue, Sep 16, 2003 at 05:59:21AM +0900, Jun-ichiro itojun Hagino wrote:
> 	it seems that pkgtools/libnbcompat and libnbcompat included in
> 	pkgtools/pkg_install does not compile on OpenBSD 3.4/i386 (ELF),
> 	due to some differences in evaluating expanded __weak_alias().
> 	do we really need __weak_alias in libnbcompat?

No, it doesn't.  The libnbcompat sources aren't quite clean yet, and
this is another thing we'll need to clean up.


	-- Johnny Lam <>