Subject: ap2-php4 creates a buggy
To: None <>
From: Ewald =?iso-8859-1?Q?B=F6rger?= <>
List: tech-pkg
Date: 09/08/2003 02:59:42

I've been busy all day just trying to upgrade my Apache 1.3.x/PHP4.1.x to=20
Apache 2.x/PHP4.3.3
First I've tried the binary packages as my current install is binary too.
This worked, but I was shocked to find all mysql support is disabled by=20
default and there's no way to turn it on?!?
besides I needed the pcre-regex functionality too.

So, I delved into the pkgsrc tree, fully updated it and edited the=20
www/php4/Makefile.php to make it include mysql and pcre-regex and enable=

After all had compiled (that's about an hour or so on my machine :(),=20
apache couldn't start:
Syntax error on line 234 of /usr/pkg/etc/httpd/httpd.conf:
  Cannot load /usr/pkg/lib/httpd/ into server:=20
/usr/pkg/lib/httpd/ Undefined PLT symbol "link" (reloc type =3D=
7, symnum =3D 1672)

also got this error after another compile with symbol 'tempnam' IIRC.
Compiling already gives the warning
Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).

Which is quite useless as apachectl doesn't read it :) (I can ignore it,=20
but apachectl can't and just refuses to start apache).

So, for the moment I'm back at the setup I get when I install the binary=20
ap2-php-4.2.3 (thus with apache2-2.0.44 and php4.2.3). But without the=20
mysql support that I really need!
Is there no other way than completely recompile everything? The windows=20
version just comes with mysql support compiled in?

Trying to be clever I even recompiled the 4.3.3 pkgsrc for PHP with all=20
options enabled, but Apache doesn't see it (probably because=20
/usr/pkg/lib/httpd/ isn't updated?)

Anyway: HELP!
I just wasted a lot of time I could have spent better :( I even got to the=
point of actually thinking about putting an extra win2k box next to my=20
NetBSD machine :((

System: NetBSD/i386 1.6.1 on PentiumII-233.

Ewald B=F6rger,
Enschede, The Netherlands