Subject: Re: pkgtools/pkg_install broken on linux
To: Pavel Arno?t <>
From: Johnny C. Lam <>
List: tech-pkg
Date: 09/03/2003 07:07:51
On Tue, Sep 02, 2003 at 03:45:36PM +0200, Pavel Arno?t wrote:
> compilation of pkgtools/pkg_install on linux results in this error
> message:
> -DDEF_LOG_DIR=\"/var/db/pkg\"  -I/usr/pkg/include/libnbcompat
> -I/usr/pkg/include -I. -I. -O2 -march=pentiumpro -I/usr/pkg/include -c
> file.c
> file.c: In function `fileFindByPath':
> file.c:384: `pl_entry' undeclared (first use in this function)
> file.c:384: (Each undeclared identifier is reported only once
> file.c:384: for each function it appears in.)
> file.c:384: parse error before `{'
> file.c:389: `cp2' undeclared (first use in this function)
> file.c:400: `cp' undeclared (first use in this function)
> file.c: At top level:
> file.c:412: parse error before `return'
> *** Error code 1

Update pkgtools/libnbcompat to version 20030825.  That should fix the
TAILQ problems that you're experiencing.


	-- Johnny Lam <>