Subject: Re: lightweight groff package?
To: NetBSD Packages Technical Discussion List <tech-pkg@NetBSD.ORG>
From: Todd Vierling <>
List: tech-pkg
Date: 08/21/2003 13:59:40
On Thu, 21 Aug 2003, Greg A. Woods wrote:

: It's not that simple.
: Indeed unless the pkgsrc maintainer can guarantee ABI compatability
: between the old and new library then there's no choice but to recompile
: and re-link all dependents,

This is perfectly true, and is a fear of my own.  In practice, though,
pkgsrc packages have been pretty good about this (either because of pkg
maintainers bumping majors where needed, or because the original authors
have done it right).

As an optional feature, in-place upgrades are great.  As a method for
generating redistributed binary packages, it's bad.

-- Todd Vierling <>