Subject: Solaris pkgsrc
To: None <>
From: Dima Veselov <>
List: tech-pkg
Date: 08/19/2003 19:40:22

I am using pkgsrc on Solaris 8/sparc and have problems compiling some packages.

Compiling OpenSSL needs Perl and crashes compiling it, because ld have'nt -E flag.
Two questions:
1. Is there a way not to compile Perl, but use system /bin/perl?
2. What should be done with ld, maybe some Solaris patches requires to be applied?

Also apcupsd package can't be compiled, output follows:

===> Building for apcupsd-3.8.6nb1
(internal libintl disabled)
(cd lib; /usr/pkg/bin/gmake)
gmake[1]: Entering directory `/usr/pkgsrc/sysutils/apcupsd/work/apcupsd-3.8.6/lib'
gmake[1]: Nothing to be done for `all'.
gmake[1]: Leaving directory `/usr/pkgsrc/sysutils/apcupsd/work/apcupsd-3.8.6/lib'
gmake: *** No rule to make target `-L/usr/pkg/lib', needed by `apcupsd'.  Stop.
*** Error code 2

bmake: stopped in /usr/pkgsrc/sysutils/apcupsd

Can somebody help me to fix it?

Thanks for reading.

And thanks for pkgsrc system on Solaris anyway - great to use it.

Sincerelly yours