Subject: Re: libiconv not working
To: Stoned Elipot <>
From: Steven M. Bellovin <>
List: tech-pkg
Date: 08/09/2003 12:47:56
In message <>, Stoned El
ipot writes:
>On Sat, Aug 09, 2003 at 03:55:51AM -0400, Steve Bellovin wrote:
>> I'm having trouble trying to build a number of different packages that 
>> depend on libiconv.  Here's one example:
>> I've seen pkg/22262, but the proposed fix seems to be package-specific. 
>> I'm seeing this in a number of different places.  I'm running -current 
>> of 4 August with a newly-cvs'd pkgsrc.
>Aren't you using packages compiled a little while back when
>/usr/include/iconv.h did not exist? If so you may have a package saying
>that it need -liconv (as recoded in a says gtk-config like script) but now
>your system does have /usr/include/iconv.h (but not libiconv.*) so
>converters/libiconv/ only links /usr/include/iconv.h in the
>buildlink area, it does not link the libiconv packages includes
>and libs, hence the linking is failing.
>Try identifying the package concerned and rebuild it.

Any hints on how to do that?  I've pkg_delete'd everything in sight 
that appears to be a prerequisite.

		--Steve Bellovin,