Subject: Re: Removal of gaim-gtk1
To: Rafal Boni <>
From: Julio M. Merino Vidal <>
List: tech-pkg
Date: 07/23/2003 12:29:37
On Tue, 22 Jul 2003 20:10:32 -0400
Rafal Boni <> wrote:

> In message <>, you write: 
> -> > Apparently, the 0.60+ applet requires the gnome2 panel (or KDE3.1), so I'd
> -> > need to wholesale update my gnome-1.4 based desktop with gnome2 to actuall
> -> y
> -> > get that support back (I may try this on my fast dual-CPU box, but on my
> -> > laptop even "make print-run-depends-list" in pkgsrc/x11/gnome-panel takes
> -> > an unbearably long time :-/).
> -> 
> -> gnome2 has a bigger dependancy tree than gnome1 because packages are more
> -> fine grained.  But I *think* it takes less time to build ;)
> It it reasonably usable?  Will I spend days getting it to run, or can I
> expect an upgrade from gnome1 to be fairly painless?

rh@ has done a lot of work on gnome2, and I think he is using it as his
primary desktop.  When I tried it several weeks ago, it worked quite well
(aside from metacity, which I find less functional than sawfish heh).

> -> No idea about this... but if you, as the maintainer, have any objection...
> -> I can't remove it hehe.
> I don't really want to maintain the old stuff, so my objection doesn't
> carry a lot of weight.  Is there a generaly policy wrt to gnome1 vs.
> gnome2, for example?  If so, I'd do whatever we've done for that (ie,

There are several packages where gtk1 versions are kept (xchat comes to
my mind).  But I think there is not any written policy about this...

> I'd keep it as long as we have gnome1 packages still around, maybe
> renaming it to "gaim-gnome1" like some of the other gnome packages).

That could be good, imo.

BTW, there is gaim 0.59.9 on their site while we have 0.59.8.  If we are
going to keep it, an update may be good.


Julio M. Merino Vidal <>
The NetBSD Project -