Subject: Re: upgrading libtool
To: Nick Hudson <>
From: Chris Jones <>
List: tech-pkg
Date: 07/11/2003 09:22:59
Nick Hudson wrote:
> On Thursday 10 July 2003 7:44 pm, Chris Jones wrote:
>>Jeremy C. Reed wrote:
>>>I am getting errors like:
>>>** WARNING **: could not find signal handler
>>>Gtk-WARNING **: gtk_signal_handler_block_by_data(): could not find handler
>>>containing data (0x8669D00)
>>>Gtk-WARNING **: gtk_signal_handler_unblock_by_data(): could not find
>>>blocked handler containing data (0x8669D00)
>>I see these errors, too.  According to a message I found from one of the 
>>developers, the problem is that older versions of libtool aren't 
>>exporting symbols from the executable (to dynamically loaded SO's, I 
>>assume).  I see hundreds of these warnings; if you're only seeing a few, 
>>then maybe your compiler or linker is different from mine.
> Can you point me at this?

It's in the PR.  Here are two links:

Somebody else wrote to me about this problem, and he provided some more 


Chris Jones