Subject: Re: libIDL broken?
To: adam morley <>
From: Lubomir Sedlacik <>
List: tech-pkg
Date: 07/11/2003 12:31:21
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable


On Thu, Jul 10, 2003 at 01:51:56PM -0700, adam morley wrote:
> So I've been postponing my work on pkgsrc on solaris 8 while futsing
> with it on Solaris 9.  Using the binary kit, its going along very
> nicely things are working just peachy.  Then I ran into:
> gcc -O -I/usr/pkgsrc/net/libIDL/work/.buildlink/include
> -Wl,-R/usr/pkg/lib -o .libs/tstidl tstidl.o -Wl,-R/usr/pkg/lib
> -Wl,-R/usr/pkg/lib -Wl,-R/usr/pkg/lib
> -L/usr/pkgsrc/net/libIDL/work/.buildlink/lib ./.libs/
> -L/usr/pkg/lib /usr/pkg/lib/ -liconv
> /usr/pkg/lib/ -lc /usr/pkg/lib/ -R/usr/pkg/lib
> Undefined                       first referenced
>  symbol                             in file
> __IDL_lex_cleanup                   ./.libs/
> __IDL_prev_token_line               ./.libs/
> __IDL_in                            ./.libs/
> __IDL_lex_init                      ./.libs/
> __IDL_cur_token_line                ./.libs/
> __IDL_lex                           ./.libs/
> ld: fatal: Symbol referencing errors. No output written to .libs/tstidl
> collect2: ld returned 1 exit status
> while doing bmake in meta-pkg/gnome2.  note that this is while
> compiling libIDL (one of the dependancies.)  It looks to me like -lIDL
> is missing.  I didn't see it listed as a bug here:

see "./.libs/" above.  the error itself says that the symbols
are first referenced _in_

>, so I thought I might be
> missing something obvious.  I unloopback mounted the current pkgsrc
> tree I'm using and checked one out with CVS (which reminds me, I
> didn't see a good explanation of how to do that in the pkgsrc docs,
> but I found one in the list archives), and the same problem with
> libIDL continued.
> So am I doing something totally wrong here or is this really a bug I
> should file?

i just tried to build it on Solaris 9 and had no problems.  i am using
the native compiler, though.


-- Lubomir Sedlacik <>                   --
--                  <>                   --

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.2 (NetBSD)