Subject: Re: pkgsrc on solaris 8/sparc + bmake gnome2
To: None <>
From: J. Alexander Jacocks <>
List: tech-pkg
Date: 06/24/2003 13:08:21
On Tuesday 24 June 2003 12:58 pm, you wrote:
> On Tue, Jun 24, 2003 at 06:20:13PM +0200, Julio Merino wrote:
> > Try adding the following lines to the Makefile of the package failing:
> >
> >
> > and see if that solves the problem.  BTW, fill appropiate PR's for all
> > packages that fail.
> Tried that:
> ...
> test: build
>         cd ${WRKSRC} && \
>                 ${MAKE_ENV} ${MAKE_PROGRAM} check 2>&1 | \
>                 tee ${WRKDIR}/tests.log
> CONFIG_SUB_OVERRIDE=    ${WRKSRC}/config.sub
> .include "../../devel/gettext-lib/"
> ...
> Also tried it in another part of the makefile, to no avail.  Even deleted
> the work directory once.
> I'm currently filing a pr, but I can't help but think I'm missing another
> obvious something, since this is my first time with pkgsrc.
> [snip]

FWIW, I'm having the same problem.  I'm running Solaris 9 04/03 with SMC's 
package of gcc-3.2.3.  I'm attempting to build gcc, as is recommended by the 
Solaris readme.

jaj@hephaestos[/usr/pkgsrc/devel/libtool]$ sudo bmake
===> Checking for vulnerabilities in libtool-1.4.20010614nb14
===> Extracting for libtool-1.4.20010614nb14
===> Required package libtool-base-1.4.20010614nb14: NOT found
===> Verifying reinstall for ../libtool-base
===> Checking for vulnerabilities in libtool-base-1.4.20010614nb14
===> Configuring for libtool-base-1.4.20010614nb14
loading cache ./config.cache
checking for a BSD compatible install... /usr/ucb/install -c -o root -g root
checking whether build environment is sane... yes
checking whether bmake sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found

Configuring libtool 1.4a (1.641.2.255 2001/05/22 10:39:30)

checking for gcc... gcc
checking whether the C compiler (gcc -O -I/usr/pkg/include  -Wl,-R/usr/pkg/lib 
-L/usr/pkg/lib) works... yes
checking whether the C compiler (gcc -O -I/usr/pkg/include  -Wl,-R/usr/pkg/lib 
-L/usr/pkg/lib) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking host system type... config.sub: invalid option -sun-solaris
Try `config.sub --help' for more information.
checking build system type... config.sub: invalid option -sun-solaris
Try `config.sub --help' for more information.
checking for ld used by GCC... ld
checking if the linker (ld) is GNU ld... no
checking for BSD-compatible nm... /usr/ccs/bin/nm -p
checking whether ln -s works... yes
checking for mawk... /usr/bin/nawk
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for ld option to reload object files... -r
checking how to recognise dependant libraries... pass_all
checking for object suffix... o
checking for executable suffix... no
./configure: test: unknown operator invalid
*** Error code 1