Subject: VMware3 - "expecting 30.0, got 10.0."
To: None <>
From: ptiJo <>
List: tech-pkg
Date: 06/09/2003 01:18:32

I tried to install VMware3 on NetBSD 1.6.1_STABLE.
The install went OK but when I try to start it, I get:
VMware Workstation Error:
Version mismatch with vmmon module: expecting 30.0, got 10.0.
You have an incorrect version of the `vmmon' kernel module.
Try reinstalling VMware Workstation.

Press "Enter" to continue...

I already tried (3 times) to reinstall, but nothing changed...
The procfs is mounted: procfs on /proc type procfs (read-only, local)
/etc/rc.conf is filled with the /usr/pkg/etc/rc.d/vmware content
And the emul part seems OK:
emul.linux.kern.ostype = Linux
emul.linux.kern.osrelease = 2.4.18
emul.linux.kern.osversion = #0 Wed Feb 20 20:00:02 CET 2002
The installed packages are:
# pkg_info | egrep -i "linux|vmware"
 vmware-module-3.2.2 Kernel modules for the VMware 3.x emulator
 suse_base-7.3nb4    Linux compatibility package
 suse_x11-7.3nb2     Linux compatibility package for X11 binaries
 suse_vmware-7.3     Linux compatibility package to support running VMware
 vmware-3.2.1        VMware emulator 3.x

What can explain this strange behaviour ?

Thanks for answers,