Subject: Re: VCD playback working at all on i386 1.6.1?
To: Frederick Bruckman <>
From: Todd Vierling <>
List: tech-pkg
Date: 05/31/2003 09:17:49
On Sat, 31 May 2003, Frederick Bruckman wrote:

: I get the same thing with "/dev/cdrom" symlinked to "/dev/rcd0a", but
: it does work fine when symlinked to "rcd0d"!

No difference here.  I also get check conditions using rcd0d, identical to
the previous:

cd0(pciide0:1:0):  Check Condition on CDB: 0x43 02 00 00 00 00 03 00 0c 00
    SENSE KEY:  Illegal Request
     ASC/ASCQ:  Illegal Field in CDB

My runtime output looks a lot like yours, with the difference here:

: track 01:  adr=1  ctrl=6  format=2  00:02:00
: track 02:  adr=1  ctrl=6  format=2  00:08:00
: track 03:  adr=1  ctrl=6  format=2  36:03:60
: scsi command failed: status 3 error 0
: MPEG-PS file format detected.

All I get, using rcd0d, is a stream of ~20 "scsi command failed: status 3
error 0", along with a single check condition message above; then the
decoder exits.  I never get to the "MPEG ... format detected" message.

Note that I originally tried with a known good NTSC VCD, which has slightly
different track TOC entries from the above.  Since your "good" output used a
NTSC SVCD, I retried with a similar known good disc and still no go.

Perhaps there's something in your newer mplayer patches that fixes this;
something that isn't in pkgsrc?  (For cases like yours where turning off
extras is important for speed, I try to change CONFIGURE_ARGS in pkgsrc
locally, to ensure I'm still otherwise using the "maintained" version of a
package.  My /usr/local is very close to empty.)

-- Todd Vierling <>