Subject: pan claims missing crtend.o (xs4)
To: NetBSD-help list <>
From: Rogier Krieger <>
List: tech-pkg
Date: 04/12/2003 17:34:24
Hi everyone,

the last few days I've been trying to figure out what could be wrong
with my system while trying to run the 'pan' newsreader (as found
in the pkgsrc collection, which - to my knowledge - is fully up to
date on my system).

When I try to run pan, I receive the following error:

rkrieger@karres:/# pan
Shared object "crtend.o" not found

While find can easily find the crtend.o file in a plausible location
(i.e. /usr/lib ) without any trouble.

root@karres:/# find / -name crtend.o

This happens regardless of being a regular user or root. In either
case, my PATH environment is as follows:


Compiling the pkgsrc news/gtk2-pan package went without
a problem (after the recent upgrade to the package regarding
'sigignore' as mentioned in the CVS).

Does the error message mean my system is broken? I tried
searching the various archives and usenet groups, but my
search came up dry. I also tried to recompile the various
packages pan depends upon, but without any result.
Other binaries on my system do not have this problem,
as far as I can tell.

For completeness, I added the output of ldd below.
Any insight is greatly appreciated,

Rogier Krieger

root@karres:/usr/lib# ldd /usr/pkg/bin/pan
         -lintl.0 => /usr/lib/
         -lm.0 => /usr/lib/
         -lm.0 => /usr/lib/
         -liconv.3 => /usr/pkg/lib/
         -lglib-2.0.200 => /usr/pkg/lib/
         -lgmodule-2.0.200 => /usr/pkg/lib/
         -lgobject-2.0.200 => /usr/pkg/lib/
         -lpthread.14 => /usr/pkg/lib/
         -lgthread-2.0.200 => /usr/pkg/lib/
         -lgdk_pixbuf-2.0.200 => /usr/pkg/lib/
         -lX11.6 => /usr/X11R6/lib/
         -lXext.6 => /usr/X11R6/lib/
         -lXi.6 => /usr/X11R6/lib/
         -lXrender.1 => /usr/X11R6/lib/
         -lfreetype.9 => /usr/pkg/lib/
         -lexpat.4 => /usr/pkg/lib/
         -lfontconfig.1 => /usr/pkg/lib/
         -lXft.2 => /usr/pkg/lib/
         -lpango-1.0.200 => /usr/pkg/lib/
         -lpangoxft-1.0.200 => /usr/pkg/lib/
         -lpangox-1.0.200 => /usr/pkg/lib/
         -lgdk-x11-2.0.200 => /usr/pkg/lib/
         -latk-1.0.200 => /usr/pkg/lib/
         -lgtk-x11-2.0.200 => /usr/pkg/lib/
         -lstdc++.4 => /usr/lib/
         -laspell.15 => /usr/pkg/lib/
         -lpspell.15 => /usr/pkg/lib/
         -lgtkspell.0 => /usr/pkg/lib/
         -lz.0 => /usr/lib/
         -lxml2.7 => /usr/pkg/lib/
         -lresolv.1 => /usr/lib/
         -lgnet-1.1.7 => /usr/pkg/lib/
         -lc.12 => /usr/lib/
         crtend.o => not found