Subject: Re: libtool problems when buildinglinking net/bind9 under Linux
To: Sebastian P. <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 03/19/2003 09:56:44
On Wed, 19 Mar 2003, Sebastian P. wrote:

> > I am looking at mk/buildlink2/fake-la to see why it is missing an
> > argument. The $version appears to be blank.

> i had a similar problem too. the cause was that i had no
> file in /usr. the solution was to create that .la file (take another .la
> file as a template ...)

Thanks for the lead.

I tried to make a couple, but received:

 libtool: link: `/usr/lib/' is not a valid libtool archive

But I am not sure of the format. Doing a search for the file on the net
didn't help. I did find one that I extracted from an RPM which I also
tried to base mine on.

I did look at a few examples of different libtool archives and at the on a NetBSD box.

I have a share/libtool/ tool as installed from
libtool-base-1.4.20010614nb13 package.

Can anyone point me documentation on fixing this?

Can anyone provide a working for my system?

Why would my system be missing it? (It was Debian Linux; the Debian
packages do not provide any file, but they do provide and libpthread.a.)

The files I have are:
 /usr/lib/  (I created this .la)

This pthread was installed when I built and installed glibc 2.2.5 (back in
November.) I have built bind9 since then, so I am not sure what changed
between then and now. I have my build and install logs and I never had a before. (I guess maybe something changed with the
buildlink2, but I don't know.)

One that I tried follows:

dependency_libs=' -L/usr/lib'

   Jeremy C. Reed