Subject: Re: errors while building KDE
To: Nathan J. Williams <>
From: Hubert Feyrer <>
List: tech-pkg
Date: 03/15/2003 06:04:00
On Fri, 14 Mar 2003, Nathan J. Williams wrote:
> > System: an x86 running current about a week old, + XFree 4.3
> >
> > Event: while building kde3, this happened:
> >From the trace that Hubert posted, that looks a lot like the bug in
> __cxa_finalize() that was present from about 3/1 to 3/4. Is your
> "about a week old" in that range? You should have rev 1.15 of
> src/lib/libc/stdlib/atexit.c; rev 1.14 is the problem version.

I made sure I have a with that version, still the same error

assertion "next != 0" failed: file
"/usr/cvs/src-current/lib/libpthread/pthread_run.c", line 117, function
[1]   Abort trap (core dumped) /usr/X11R6/qt3/b...

> I've tried to reproduce this, in case it's something else, but my kde3
> build blows out much earlier. It also dies in uic, although when
> trying to build qt3-tools:
> gmake[3]: Entering directory `/u1/nbsd/pkgsrc/x11/qt3-tools/work.i386/qt-x11-free-3.1.1/tools/designer/designer'
> /u1/nbsd/pkgsrc/x11/qt3-tools/work.i386/qt-x11-free-3.1.1/bin/uic -L /u1/nbsd/pkgsrc/x11/qt3-tools/work.i386/qt-x11-free-3.1.1/plugins listboxeditor.ui -o listboxeditor.h
> gmake[3]: *** [listboxeditor.h] Segmentation fault (core dumped)

No idea, but it's uic too that's blowing up.

 - Hubert

Want to get a clue on IPv6 but don't know where to start? Try this:
* Basics ->
* Setup  ->
Of course with your #1 IPv6 ready operating system ->