Subject: Re: installing glade2
To: James K. Lowden <>
From: Lubomir Sedlacik <>
List: tech-pkg
Date: 03/12/2003 16:56:14
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable


On Tue, Mar 11, 2003 at 10:38:32PM -0500, James K. Lowden wrote:
> Using current pkgsrc, I tried to install Glade2, but =20
> =3D=3D=3D> glade2-1.1.2nb2 is marked as broken:
> =3D=3D=3D> Incompatible with the new libgnomedb. Will be fixed in next re=
> *** Error code 1
> I searched the archives, and I found a patch, below. =20
> Rene Hexel said he liked the patch and would apply it.  AFAICT, he
> didn't, and I'm chary of modifying pkgsrc unless I *really* know what
> I'm doing (which isn't very often). =20
> So, I'd like to know, should I apply this patch locally, or was there
> an offlist discussion arriving at reasons not to use it? =20

i can't see how is the attached patch related to this issue.

> I'd like to run Glade2 without Gnome or Gnome2.  The machine in
> question has no GTK1 on it. =20

you can't use Glade2 with the libgnomedb in pkgsrc without updating it
to cvs version (where the incompatibility is fixed, but the patch is
non-trivial - you can try to fix this if you want, though).  you can
also use netbsd-1-6-1 branch of pkgsrc with older libgnomedb or just
wait for new release of Glade2.


-- Lubomir Sedlacik <>                   --
--                  <>                   --

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.1 (NetBSD)