Subject: Re: CVS commit: othersrc/bootstrap-pkgsrc
To: None <tech-pkg@NetBSD.ORG>
From: MLH <>
List: tech-pkg
Date: 02/28/2003 06:24:02
On 27 Feb 2003 23:35:00 -0600, grant beattie wrote:
> On Fri, Feb 28, 2003 at 12:55:22AM +0000, MLH wrote:
>> > That seems fine. I think it also makes sense for and friends
>> > to display a helpful message and die cleanly if the required tools are
>> > not found.
>> Speaking of, is there any chance that bootstrap-pkgsrc can be fixed
>> for Solaris?
>> Right now, /opt/SUNWspro/bin/cc can't be used because the recommended
>> /usr/ucb/install trashes SUNWspro binaries when it tries to strip
>> them and /usr/sbin/install uses different arguments. And you can't
>> use std gcc version 3.x because it apparently isn't compatible with
>> how devel/m4's configure handles /usr/ucb/install's test for make.
>> And gcc version 2.95.3, if you do build it outside of pkgsrc, still
>> doesn't handle things like automatically including socket libraries,
>> etc.
> I've just done a fresh bootstrap on a fresh Solaris 9 install with
> both gcc 3.2.2 (from Sun Freeware) and SUNWspro 5.0. 
> Both worked fine and I was able to install packages without a hitch,
> so I'm not sure I fully understand this problem. Could you provide
> some examples?

Same as before that I posted.  The -s <strip> option of /usr/ucb/install
trashes executables created by Sun WorkShop 6 update 2 C 5.3 cc.
Either you have to use gcc or you have to find and build some
version of install that has the same arguments as /usr/ucb/install
and that doesn't trash Workshop's executables.

Actually, I think the problem was that ucb/install called some
version of strip or such and something was funky with that that I
can't remember, but it was apparently easier to build another
install out of src/ than to fix that problem. /usr/ucb/install
appears to work fine with gcc 3.0.3 executables. (I wrote this all
up back when, but can't find the final message about what was
happening with strip).

> Some of the problems you mention are package specific problems, such
> as devel/m4. /usr/ucb/install is the BSD compatible one, and ~all
> autoconf'd software will use it and not /usr/sbin/install.

So you can't use Sun WorkShop 6 update 2 C 5.3 cc with it if the
install/strip problem isn't fixed.

> As far as I'm aware, gcc doesn't automatically add libsocket and
> libnsl (is that what you meant?) and to an extent, nor does pkgsrc.
> Packages which do not auto detect their library requirements typically
> have:
> LDFLAGS+=	-lnsl -lsocket
> specified in their package Makefile.

Yep, using pkgsrc, but it apparently doesn't pick those up correctly
with a hand-built gcc version 2.95.3 on Solaris. Haven't tried to
figure that one out yet. Was hoping to build lang/gcc and try that,
but haven't because devel/m4 doesn't build.