Subject: Re: CVS commit: othersrc/bootstrap-pkgsrc
To: None <tech-pkg@NetBSD.ORG>
From: MLH <>
List: tech-pkg
Date: 02/28/2003 02:30:34
On 27 Feb 2003 20:00:00 -0600, Lubomir Sedlacik wrote:
> --cvVnyQ+4j833TQvp
> Content-Type: text/plain; charset=us-ascii
> Content-Disposition: inline
> Content-Transfer-Encoding: quoted-printable
> On Fri, Feb 28, 2003 at 12:55:22AM +0000, MLH wrote:
>> Speaking of, is there any chance that bootstrap-pkgsrc can be fixed
>> for Solaris?
>> Right now, /opt/SUNWspro/bin/cc can't be used because the recommended
>> /usr/ucb/install trashes SUNWspro binaries when it tries to strip them
> oh, do you _still_ have this problem?  i thought that we solved this a
> year ago..  can you please provide more information?  e.g. truss log of
> the install command with -s and without it, patch revisions of relevant
> packages on your system, etc.

Yep. I got around it before by spending a couple of days hand-building
everything from scratch out of /src. There were so many problems
with pkgsrc packages after doing all of that that I gave up on
trying to use it. I checked out bootstrap several times since and
experienced the same problems, so didn't continue. This time, I
thought I'd give it another try, and was also trying to help another
NetBSD person also using Solaris to do this - more incentive.  He
couldn't even get bootstrap built even though he followed the
bootstrap directions for Solaris. I finally remembered what I had
gone through before and we walked through it again on different
machines, eventually using all three different compilers.

I'm not trying to whine here because I well understand how difficult
this can be, but it would amaze me that anyone without intimite
knowledge of /pkgsrc and /src could ever build for Solaris using
bootstrap and compile more than a few trivial pkgsrc packages.
Actually, I was somewhat trying to defend it to the other person,
who is an experienced admin and NetBSD person, and I finally had
to give up tryin gto defend it. He finally got it working somewhat,
using gcc version 2.95.x - built outside of pkgsrc, but still has
to hand-patch packages to get it to work.

Have you really tried building bootstrap from *scratch* on Solaris