Subject: Re: galeon
To: None <>
From: Rene Hexel <>
List: tech-pkg
Date: 01/29/2003 08:15:47
On Tue, 2003-01-28 at 23:59, wrote:

> Is this correct way to fix it? 

  You'd need to check whether -lpthread is required first.  I.e., you
can do this by including and then checking whether
PTHREAD_TYPE == "native".

  However, I believe this really needs to be fixed in mozilla. 
Mozilla's should be linked against libpthread under systems
with native threads.  Otherwise, such a check needs to be added to every
package linking against mozilla's libraries.