Subject: Python GD package
To: None <>
From: D'Arcy J.M. Cain <>
List: tech-pkg
Date: 01/04/2003 09:33:30
Does anyone know if there are any known issues with the GD package and Python 
versions greater than 2.1?  Any reason that we don't make the following 
change?  I have tried with and without threads (the python22pth seems to be 
needed if you have that version of Python installed) and do not see any 
problems.  I would like to get rid of older versions if I can.

Index: Makefile
RCS file: /cvsroot/pkgsrc/graphics/py-gd/Makefile,v
retrieving revision 1.10
diff -u -r1.10 Makefile
--- Makefile    2002/09/21 23:46:50     1.10
+++ Makefile    2003/01/04 14:24:49
@@ -19,9 +19,11 @@
 ALL_TARGET=    default

 # this pkg uses
+PYTHON_VERSIONS_ACCEPTED=      20 21 22 22pth
 BUILDLINK_DEPENDS.python20=    python20>=2.0.1nb1
 BUILDLINK_DEPENDS.python21=    python21>=2.1.1nb1
+BUILDLINK_DEPENDS.python22=    python22>=2.2
+BUILDLINK_DEPENDS.python22pth= python22pth>=2.2


D'Arcy J.M. Cain <>