Subject: Re: pkgtools/pkg_install fails under Linux (due to HAVE_STATVFS?)
To: Amitai Schlair <>
From: Lubomir Sedlacik <>
List: tech-pkg
Date: 12/22/2002 10:33:56
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, Dec 22, 2002 at 10:17:28AM +0100, Lubomir Sedlacik wrote:
> this turned out to be local problem with pkg_install installed over
> zoularis.  zoularis pkg_* are in ZOULARISBASE/bin while pkg_install
> ones are in ZOULARISBASE/sbin and i had bin before sbin in my PATH so
> it always used the old version of pkg_info for PKGTOOLS_VERSION check.
> this is also a note for all zoularis users who will upgrade
> pkg_install directly from zoularis without bootstrap-pkgsrc.

i hunted down this a bit more and at the end there was a problem with
mk/ which was not prepared to cope with situation when
pkg_install is installed over zoularis and PKG_TOOLS_BIN was set to the
old tools or bootstrap-pkgsrc tools only.  finally everything works as
expected :).

now some tea and try to fully wake up.. *sigh*


-- Lubomir Sedlacik <>                   --
--                  <>                   --

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.1 (NetBSD)