Subject: ap_perl & ap2_perl broken on 1.6 macppc
To: None <>
From: Daniel Eggert <>
List: tech-pkg
Date: 12/14/2002 12:37:15
What is the likelyhood of someone fixing this for macppc?


On torsdag, jan 1, 1970, at 02:30 Europe/Copenhagen, Daniel Eggert 

> I'm unable to get mod_perl to run on 1.6-macppc. All I get is
>     Syntax error on line 212 of /usr/pkg/etc/httpd/httpd.conf:
>     Cannot load /usr/pkg/lib/httpd/ into server: 
> /usr/pkg/lib/httpd/ Unsupported relocation type 10 in 
> non-PLT relocations
> It's been posted as PR pkg/13771:
> This 'fix' has been supposed,:
> But Jason R Thorpe noted, that this patch is not correct:
> 	That reloc type is not a PIC reloc.  If it is present in the mod_perl
> 	module, it means that it was not compiled as PIC code, which is the
> 	real problem.
> Does anyone know, if there's a work-around? I'd very much like to get 
> mod_perl working on my NetBSD macppc machine.
> Thanks in advance for any feedback.
> Daniel