Subject: make update broken?
To: None <>
From: Martin Husemann <>
List: tech-pkg
Date: 12/13/2002 21:06:45
What's wrong here?

(I know how to work around it, but this isn't expected behaviour, right?)


[/usr/pkgsrc/www/apache] root@night-porter # make update
===> Resuming update for apache-1.3.27nb3
===> Installing for apache-1.3.27nb3
===>  apache-1.3.22 is already installed - perhaps an older version?
*** If so, you may wish to ``pkg_delete apache-1.3.22'' and install
*** this package again by ``make reinstall'' to upgrade it properly,
*** or use ``make update'' to upgrade it and all of its dependencies.
*** If you really wish to overwrite the old package of apache-1.3.22
*** without deleting it first, set the variable "FORCE_PKG_REGISTER"
*** in your environment or the "make install" command line.
*** Error code 1