Subject: pkgtools/pkg_install vs. devel/gettext-lib/
To: NetBSD Packages Technical Discussion List <tech-pkg@NetBSD.ORG>
From: Greg A. Woods <>
List: tech-pkg
Date: 12/02/2002 16:17:29
Ever since this revision, which is entirely well intentioned of course,
devel/gettext-lib has, in some environments at least, required
pkg_install-20021114 because it implements this check using the new
"pmatch" sub-command of pkg_admin which is only available in the
20021114 release of pkg_install.

revision 1.7
date: 2002/10/16 22:07:47;  author: jlam;  state: Exp;  lines: +32 -10
Create GETTEXT_REQD variable that defaults to "0.10.35nb1" and represents
the version of the gettext library needed by a package.  The system libintl
is considered to be equivalent to "gettext-lib-0.10.35nb1".  Add a few
additional bits to fool newer configure scripts into accepting the system
libintl if GETTEXT_REQD == 0.10.35nb1.

Is there a better way to do the check necessary, or do we have to bite
the bullet and force everyone to upgrade to pkg_install-20021114?

								Greg A. Woods

+1 416 218-0098;            <>;           <>
Planix, Inc. <>; VE3TCP; Secrets of the Weird <>