Subject: getting clisp to build... please help!
To: None <>
From: Paul NCC/CS <>
List: tech-pkg
Date: 11/05/2002 14:13:38
Hi folks,

I'm still trying to get clisp to build but I'm stumped so
could someone please give me some help and just point
me in the direction of somewhere where I could help
myself please?  I don't know what else to do at the moment.

Because pkgsrc failed:
I tried to download the raw tarball from ""
and install it using their instructions. But it bombed in
a similar fashion that it does when I try to build it using
pkgsrc.    It's basically during the configure script in the
raw tarball build.
It does this, which I did manually in one of the build

lewy% test '!' -s minitests.output.sparc-unknown-netbsdelf1.5.2
lewy% echo $status

At this point configure stops, as it obviously didn't want to
get a '1' returned from this test.

So it doesn't look like it's up to running make yet I don't think.
It's just failing in the configure stage.

My machine is a sparcstation 5 and it runs netbsd 1.5.2
It originally had pkgsrc 1.5.2 that came with it and I built
several packages with it no problem. Then I wanted a pkg
that didn't exist in the 1.5.2 pkgsrc tree. So I did what I
understand is the correct thing to do and I installed the
newer 1.5.3 pkgsrc tree. And then built the pkg that I wanted

Now later I go to build clisp and it said that it didn't want the old
version of libtool, and so I did what it asked and updated
my version of libtool. This worked no problem.

It's just now when I go to make clisp in pkgsrc I get :

lewy# make
===> Building for clisp-2.27
cd /mnt/raid/pkgsrc_153/lang/clisp/work/clisp-2.27/src/avcall && make
cd /mnt/raid/pkgsrc_153/lang/clisp/work/clisp-2.27/src/callback && make
cd vacall_r; make all
cd trampoline_r; make all
test -d bindings || mkdir bindings
builddir="`pwd`"; cd avcall && make && make check && make install-lib
libdir="$builddir" includedir="$builddir"
./minitests > minitests.out
uniq -u < minitests.out > minitests.output.sparc--netbsdelf
test '!' -s minitests.output.sparc--netbsdelf
*** Error code 1

*** Error code 1

*** Error code 1

*** Error code 1


Or when I go to do ./configure in a seperate raw tarball from
the clisp website, I get :

ranlib .libs/libcallback.a
(cd .libs && rm -f && ln -s ../
gcc -O  -I. -I../../ffcall/avcall -c ../../ffcall/avcall/minitests.c
/bin/sh ./libtool --mode=link gcc -O  -x none minitests.o
-o minitests
gcc -O -x none minitests.o -o minitests  ./.libs/libavcall.a
./minitests > minitests.out
uniq -u < minitests.out > minitests.output.sparc-unknown-netbsdelf1.5.2
test '!' -s minitests.output.sparc-unknown-netbsdelf1.5.2
*** Error code 1


So it's the same problem to do with some sort of test on
minitests.output.sparc blah blah.

I wonder if this file has been created correctly by libtool?
I don't know.

Could someone from tech-pkg help me please?
Even  just a hint to tell me what to research would be a




Australian Bureau Of Meteorology