Subject: GTK2/GLIB2 Apps (WAS: Re: pkgsrc/news/pan 0.[12,13] branch (GTK/GLIB
To: Dr. Rene Hexel <>
From: Brian A. Seklecki <>
List: tech-pkg
Date: 09/21/2002 19:19:03
On Thu, 15 Aug 2002 @ 11:36am (+1000), Dr. Rene Hexel wrote:

DRH> On Tuesday, August 13, 2002, at 05:04  PM, Brian A. Seklecki wrote:
DRH> > Insight anyone?  Are we waiting for a major change that will affect all
DRH> > gtk/glib apps?
DRH>    At the moment there is a freeze for pkgsrc awaiting NetBSD-1.6.
DRH> Once that's over, yes, I believe it's a good idea to update pan.

...i think we're in the clear at this point. i guess a LOT of major GTK apps are gonna be depending on gtk2/glib2
soon, as they do, how are we going to adjust?

Perhaps have duplicate packages in pkgsrc for the old branches?

A lot of KDE apps are duplates w/ v2 v.s. v3


DRH> It might make sense, though, to keep the old pan, at least for a
DRH> while, because not everyone might want to install/use gtk2 yet.
DRH>   Cheers
DRH>       ,
DRH>    Rene

later -           | _BonaFide[] = { coder, author, | /~\ The ASCII Ribbon
Brian A. Seklecki | problem solver, scholar, BOFH, | \ / Campaign Against
                  | vegetarian, runner, NetBSD     |  X  Exchange, Outlook
                  | advocate, spiritual machine }; | / \ & HTML Email

PGP: 0111 4618 0111 4618 4AB2 24EB C853 6611 75C4 A91E A7A7 4973