Subject: broken package database?
To: None <>
From: Frank Knappe <>
List: tech-pkg
Date: 09/09/2002 23:23:38

I'm afraid that my pkg system has a huge problem.

root@trinity# make install
===> Installing for kdebase-2.2.2nb1
===>  kdebase-2.2.2nb1 is already installed - perhaps an older version?
*** If so, you may wish to ``pkg_delete kdebase-2.2.2nb1'' and install
*** this package again by ``make reinstall'' to upgrade it properly,
*** or use ``make update'' to upgrade it and all of its dependencies.
*** If you really wish to overwrite the old package of kdebase-2.2.2nb1
*** without deleting it first, set the variable "FORCE_PKG_REGISTER"
*** in your environment or the "make install" command line.
*** Error code 1

*** Error code 1

*** Error code 1


root@trinity# pkg_delete kdebase-2.2.2nb1
pkg_delete: package 'kdebase-2.2.2nb1' doesn't have a prefix

Also strange:
root@trinity# pkg_info

pkg_info: show_file: can't open '+COMMENT' for reading
kdebase-2.2.2nb1    adjustkernel-1.4    Generate a kernel config

What can I do?
NetBSD 1.5.1 with pkgsrc about 10 days old 

Ciao , Frank .