Subject: Package installed even if dependency fails
To: None <>
From: David Brownlee <>
List: tech-pkg
Date: 08/23/2002 14:11:10
	In this case the ghostscript build failed, but the system still
	went ahead and installed if-psprint. Am I missing something?

/pkgsrc/print/if-psprint)23# make update
work -> /var/obj/pkg/print/if-psprint/work
pkg_info: No matching pkg for if-psprint-[0-9]*.
=> Checksum OK for if-psprint-1.5.tar.gz.
===> Extracting for if-psprint-1.5
===> Required package ghostscript{,-nox11}-[6-9]*: NOT found
===> Verifying package for ../../print/ghostscript
===> ghostscript-6.01nb4 uses X11, but /usr/X11R6 not found
===> Returning to build of if-psprint-1.5

		David Brownlee/absolute