Subject: Re: openssl-0.9.6e + release-1-4 + i386 = unhappy
To: Aaron J. Grier <>
From: Frederick Bruckman <>
List: tech-pkg
Date: 08/19/2002 11:15:11
On Tue, 6 Aug 2002, Aaron J. Grier wrote:

> On Mon, Aug 05, 2002 at 02:13:40PM -0700, Aaron J. Grier wrote:
> apparently openssl can't properly build shared libraries under 1.4
> anymore.  Fred B suggested I try building non-shared libraries, which
> worked (see attached patch), but I first had to update libc to
> /usr/lib/ in order to get strlcat and friends.

Thomas has updated 0.9.6g to build without shared libraries on 1.4.*.
Try it with Makefile v 1.58 (or 1.59).

> there also appeared to be a bug in; also contained in the
> attached patch.  after successfully getting openssl linked, archived,
> and installed, packages pulling in openssl/ were running in
> circles trying to fill the empty dependency ":../../security/openssl"

BUILDLINK_DEPENDS.openssl was not being defined for all cases. agc
fixed that in v 1.19.

> already my ELF pmax machine is grumping at me:

[I'm copying this to port-pmax.] If this is a reproducible problem
with openssl-0.9.6g we could do the same thing as for NetBSD 1.4* --
build non-shared -- unless somebody has a better idea.