Subject: Re: Different types of JDK's
To: None <>
From: Jan Schaumann <>
List: tech-pkg
Date: 07/04/2002 10:43:08
Erik Mattsson <> wrote:
> I want to use the latest jdk available, which means that I need to install the
> lang/sun-jdk1.3 package. No problem yet, but when I want to install
> the devel/jakarta-ant package, which depends on textproc/crimson that
> depends on the lang/jdk package. The land/jdk package is jdk 1.1.8 and
> it conflicts with the lang/sun-jdk1.3 package and therefore the whole
> installation process fails.

I'm not sure if jakarta-ant depends on jdk1.1.8 in particular, but if
you're sure it will work with sun-jdk1.3, you can set PKG_JVM to
"sun-jdk" either manually or in the Makefile.  That should then work

"I am so amazingly cool you could keep a side of meat in me for a 
month. I am so hip I have difficulty seeing over my pelvis."