Subject: Re: same 1.5.3 and 1.6 tagged pkgsrc?
To: Jeremy C. Reed <>
From: Dave Burgess <>
List: tech-pkg
Date: 06/11/2002 07:52:43
Quoting "Jeremy C. Reed" <>:

> > > Since it seems like 1.5.3 and 1.6 are close to being released at same
> > > time, I think it may be useful if they used identical pkgsrc.
> > > But I guess that could be confusing. Because possibly a package built
> with
> > > i386 under 1.6 may have same name and version number but be different
> that
> > > the 1.5.2 package (with same version).
> > The OS where you build the package is moot.
> >
> > I have servers in every possible version from 1.5 through 1.6_Beta1.  I
> use
> > exactly the same pkgsrc for all of them.  I do mean exactly, too - it is
> a
> > single NFS share.
> I understand that you can use same pkgsrc for all -- that is why I made
> this suggestion (to tag at same time).

The only time a tag would be appropriate would be on a compiled package.  The 
pkgsrc system itself wouldn't care (IMHO).

One thing that just occurred to me would be to change the tar.gz filename 
semantic to include the version number of the kernel under which it was built.

> But I am assuming that some packages built on 1.6 may not work properly on
> 1.5.x.

Count on it - but I seldom build packages to be installed - I rebuild each 
package on each server, since they all have different options and things 

> Do you use the same packages all built on 1.6 on your 1.5 systems?

No, but the 1.5 packages seem to work fine on the 1.6 server.  Like I said, I 
have a lot of different versions of NetBSD running on about 30 servers, so my 
mileage obviously varies.  Once we actually release 1.6, I'll be upgrading 
everything at once (just like I did at 1.5).  Until then, I "make clean ; make 
update" whenever I need a package to be installed.

> (I can't think of any examples. Maybe some linux compat packages are
> different without having different version numbers?)

There's a facility in the packages now that allows us to limit the versions of 
the systems we load the packages on - in fact, I found one the other day that 
limited us to 1.5.  I don't remember which one - I was in a hurry.

I think you've actually hit the canonical counter-example.  All of the Linux 
stuff "just works" regardless of version (AFAIK).  With the exception that the 
program interface between 1.5 and 1.6 are different, there shouldn't be any 
reason to fear the update.

Dave Burgess
Chief Technology Officer
Nebraska On-Ramp, Inc
Bellevue, NE

This mail sent through IMP: