Subject: Re: problem building galeon and don't know why
To: NetBSD Packages Technical Discussion List <>
From: Frederick Bruckman <>
List: tech-pkg
Date: 05/07/2002 06:24:04
On Tue, 7 May 2002, Greg A. Woods wrote:

> For reasons that made no sense a the time, and are making less sense
> every day, the powers at be decided not to give the fixed glib a new
> PKGREVISION (i.e. call it 1.2.10nb1).  I still don't think it's too late
> to fix this mistake -- better sooner than later!

[See pkg/15822.] It looks like we need to bump the requirement for
gtk+, too. If we do that, we also need to bump the PKGREVISION and
dependencies for everything that depends on glib and gtk+, so people
won't get half way through installing "gnome" before the package tools
get to a (new) package that balks at the version of glib and gtk+.
This would, however, be a massive, senseless inconvenience to folks
whose glib and gtk+ packages are already up-to-date. Is there any
chance that glib, gtk+ or pth are due for an update anyway? It would
be a lot better for everybody if all this churn were to be associated
with a real update.