Subject: Serious troubles with MySQL (compiling)
To: None <,>
From: Karo Salminen <>
List: tech-pkg
Date: 05/07/2002 14:17:07

I have serious troubles with MySQL.
I compiled it from pkgsrc when I was using 20020427-1.5.3_RC2 (i386) snapshot 
and it worked fine. Few days after (01.05.2002) that I decided to compile custom kernel and 
userland. I fetched them with CVS (with --rnetbsd-1-5) (from, 
compiled my custom kernel <> and
userland. After that MySQL reported errors to logs and didn't start
<>. I thought about compiling it again,
because I didn't have any other ideas how to deal with it (I asked from #NetBSD however).

I removed the packages and started to compile it from pkgsrc. It seems to go fine until
it stucked to "./gen_lex_hash > lex_hash.h". The process ate whole processor time and
didn't ever end (I ran it almost 24 hours and the processor's speed is 166MHz).
Again no-one could help me so I thought about compiling it from the official sources, both
with make and gmake. The very same problem appeared.

After discussion with Hubert Feyrer on IRC I thought about mailing these mailinglists.
However I found some similiar reports with Google 

Below is some extra information:
kernel: NetBSD 1.5.3_RC2 NetBSD 1.5.3_RC2 (experiment) #0: Tue Apr 30 21:35:58 EEST 2002 i386
272 -r-xr-xr-x  1 root  wheel  266544 May  1 08:17 /bin/ls*

Please mail me privately too!

Thanks in advance,
Karo Salminen <>, <>