Subject: Re: problem building galeon and don't know why
To: Jeremy C. Reed <>
From: Greg A. Woods <>
List: tech-pkg
Date: 05/07/2002 02:44:52
[ On Monday, May 6, 2002 at 23:01:08 (-0700), Jeremy C. Reed wrote: ]
> Subject: problem building galeon and don't know why
> I am building galeon-1.2.1 from pkgsrc, but it fails after a bunch of
> "warning"s. (The makefile is version 1.28.)
> Can someone look at the LOG to see what really made it fail?

I think your 'devel/glib' package is not up-to-date.....

Ah, yes, there it is near the top:

	===> Required installed package glib>=1.2.8: glib-1.2.10 found                  
    [[ .... ]]
	=> Creating wrapper script /usr/local/pkgsrc/www/galeon/work/.buildlink/bin/glib
	The installed glib package is broken, please rebuild it from source.            
	For more information, see PR 14150.                                             

For reasons that made no sense a the time, and are making less sense
every day, the powers at be decided not to give the fixed glib a new
PKGREVISION (i.e. call it 1.2.10nb1).  I still don't think it's too late
to fix this mistake -- better sooner than later!

I made the mistake of trying to upgrade my local pkgsrc gdk-pixbuf to
0.17.0, which worked fine for some things, but unfortunately I still
can't get its sibling gdk-pixbuf-gnome-0.17.0nb1 to install yet (it
builds fine but then libtool complains that
isn't a valid libtool archive!).

Maybe I'll try skipstone....  Mozilla 1.0.rc1 crashes faster than 0.9.7
did, and I didn't think to make a binary package of 0.9.9 to save it...

								Greg A. Woods

+1 416 218-0098;  <>;  <>;  <>
Planix, Inc. <>; VE3TCP; Secrets of the Weird <>