Subject: Why depending on [X]Emacs package for JDE ?
To: None <>
From: Eric Jacoboni <>
List: tech-pkg
Date: 04/08/2002 19:16:11
Yes, i know JDE without [X]Emacs is like a fish without a
bicycle... ;-)

Anyway, i'm using more a recent stable version of Emacs (21.2) than
the one provided by NetBSD packages (20.7) and wanting installing JDE,
i've found the install process look for the 20.7 package...

My Emacs was installed the usual 'traditionnal' way : configure &&
gmake install. The emacs bin is in /usr/local/bin.

Could it be possible that packages depending on [X]Emacs looks for
{emacs|xemacs} binaries (in /usr/local/bin as stock installs do), no
matter if they were installed manually or with the package system? (at
least with an install option). To install JDE, i've had to manually
comment out the DEPENDS lines in the various makefiles involved
(speedbar, jde, elib, ...) : could it be more "friendly" ?

I admit i've perhaps missed something with the package dependancy

Éric Jacoboni, né il y a 1321729666 secondes