Subject: gdk-pixbuf build trouble on alpha, buildlink related?
To: None <>
From: Jeff Rizzo <>
List: tech-pkg
Date: 03/22/2002 15:18:31
[Note: this is on NetBSD-alpha]

I just submitted a PR on this, but I was hoping someone with more
buildlink expertise than I might suggest how to work around this
until such time as it gets fixed.

Basically, some of the include directories seem not to make it:

gmake[3]: Entering directory `/usr/pkgsrc/graphics/gdk-pixbuf/work/gdk-pixbuf-0.11.0/gdk-pixbuf/pixops'
/bin/sh ../../libtool --mode=compile cc -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/pkgsrc/graphics/gdk-pixbuf/work/.buildlink/include/glib/glib-1.2 -I/usr/pkgsrc/graphics/gdk-pixbuf/work/.buildlink/lib/glib/include  -I../../gdk-pixbuf  -I/usr/pkgsrc/graphics/gdk-pixbuf/work/.buildlink/include  -I/usr/pkg/share/x11-links/include  -I/usr/pkgsrc/graphics/gdk-pixbuf/work/.buildlink/include -O2 -mieee -I/usr/pkg/share/x11-links/include -c pixops.c
mkdir .libs
cc -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/pkgsrc/graphics/gdk-pixbuf/work/.buildlink/include/glib/glib-1.2 -I/usr/pkgsrc/graphics/gdk-pixbuf/work/.buildlink/lib/glib/include -I../../gdk-pixbuf -I/usr/pkgsrc/graphics/gdk-pixbuf/work/.buildlink/include -I/usr/pkg/share/x11-links/include -I/usr/pkgsrc/graphics/gdk-pixbuf/work/.buildlink/include -O2 -mieee -I/usr/pkg/share/x11-links/include -c pixops.c  -fPIC -DPIC -o .libs/pixops.o
In file included from pixops.h:5,
                 from pixops.c:5:
../../gdk-pixbuf/gdk-pixbuf.h:29: gdk/gdk.h: No such file or directory
gmake[3]: *** [pixops.lo] Error 1

...I've tried just adding the correct directory directly to the 
Makefiles, and it gets farther, but then fails in the actual linking.

It seems like the buildlink stuff is just not configured correctly, or
the alpha setup is just different enough to make it stumble.

Does anyone have any suggestions?

Jeff Rizzo