Subject: Re: libusb and -current
To: None <>
From: Bernd Ernesti <>
List: tech-pkg
Date: 02/28/2002 09:01:35
On Tue, Feb 26, 2002 at 02:18:05PM +0200, Martti Kuparinen wrote:
> Hi!
> I have created a patch for pkgsrc/devel/libusb so that it will work
> on -current (/sys/dev/usb.h has been changed in 1.5ZA).

Did you get some devices when you try the test programm which was build
but not installed?

> What is the preferred way of checking for NetBSD 1.5Z and earlier (i.e.
> 1.[4]*, 1.5, 1.5.* and 1.5[A-Z]) in the Makefile and define -DOLD_USB_H?

I was allready thinking about it and thought about an configure check
which does the headerfile check that way libusb would also work on other
systems and this would make it easier to get it into the main source.