Subject: Re: Faulty php-4.1.1?
To: Markus Illenseer <>
From: Torelli Paolo <>
List: tech-pkg
Date: 02/27/2002 11:27:11
Markus Illenseer wrote:

>>AFAIK, preg_match() is a built-in, why do I get this error?
>  preg_match() is not build-in, it is a seperate module for PHP and must be
> installed with the /devel/php4-pcre package. Same applied for other
> modules like imap, gd, database, etc.

Oh, well, wow.
How could I know?
I sure couldn't find it written anywhere when I installed the www/php 
package (www??!?), a quick note would surely help.
I'd vote for the php-complete (meta-pkg?) too, or an option in mk.conf, 
or in the makefile. Silence is not a good solution IMHO

Thank you for the answer!

I am the LraiseR. Ph34r .\\3