Subject: Re: CVS commit: pkgsrc/sysutils/memtest
To: Tomasz Luchowski <>
From: Thomas Klausner <>
List: tech-pkg
Date: 01/30/2002 16:23:57
On Wed, Jan 30, 2002 at 01:56:36PM +0100, Tomasz Luchowski wrote:
> Thinking of packages that require new toolchain to build, at least mplayer
> comes to mind. Maybe we could invent something like REQUIRE_NEW_TOOLCHAIN
> so we woundn't have to play with ONLY_FOR_PLATFORM and set it to
> NetBSD-1.5[Y-Z]*-i386 NetBSD-1.[6-9]*-i386 ?

Actually, the good solution would be to make a 'binutils' package and
depend on that similarly to what lang/gcc/Makefile.gcc does.

Though we should do the gcc check only once in instead, not
in every Makefile (currently it's GCC_VERSION!= gcc --version with
following if in each file that depends on the new gcc).

I was planning to do the binutils package, but I'm happy if someone
beats me to it.


Thomas Klausner -
When all other means of communication fail, try words.