Subject: Re: problems with xsane (scanning)
To: None <,>
From: Daniel Senderowicz <daniel@bicho.SynchroDS.COM>
List: tech-pkg
Date: 01/10/2002 19:12:43
I removed /dev/ss0 and did MAKEDEV /dev/uk0. But now
"sane-find-scanner" does not see the scanner. Do you mean that I
have to re-compile the kernel commenting out the line defining ss* in
/usr/src/sys/arch/pmax/conf/mi.scsi? Thanks.


>On Thu, Jan 10, 2002 at 04:41:32PM -0800, Daniel Senderowicz wrote:
>> I'm not sure that this should be a PR or my own problem. I'm running
>> 1.5.2 on a pmax. I built xsane-0.80 and sane-backends-1.0.5 without
>> any problems. However when I run either xsane or scanimage it quits
>> with a segmentation fault message and dumps the core. I did MAKEDEV
>> for /dev/ss0 (it's at SCSI address #4) and when I run "sane-find-scanner"
>> it comes back with:
>If I remember correctly, you should use the uk device (unknown scsi)
>for a scanner with sane), not the ss device. I think the ss device
>should/could have been removed from NetBSD a long time ago, I do not
>think anybody is still using it. Anyway, remove the ss device from
>your kernel, add the uk device and try again and see if you get better
>results with sane.