Subject: Re: lintpkgsrc handling all DEPENDS
To: Hubert Feyrer <>
From: David Brownlee <>
List: tech-pkg
Date: 12/28/2001 13:38:56
On Fri, 28 Dec 2001, Hubert Feyrer wrote:

> On Fri, 28 Dec 2001, David Brownlee wrote:
> > 	To clarify:
> >
> > 	The ap-auth-postgresql DEPENDS is postgresql-{6.5.3*,7.0*,lib-*}
> In that case, it seems that lintpkgsrc/pkglint needs to be fixed to fully
> understand the {,} syntax, and not moan about it if one component doesn't
> match, while another one does.

	It did fully understand the {,} syntax, hence my question in the
	original mail:

>        Should it just assume that if one entry matches the current package
>        then all is OK?
>        Should we have a file that lists 'obsolete packages that are OK to be
>        left as alternatives in DEPENDS'?

	I have since implemented the first option.

		David/absolute		-- No hype required --