Subject: Re: lintpkgsrc handling all DEPENDS
To: Hubert Feyrer <>
From: David Brownlee <>
List: tech-pkg
Date: 12/28/2001 11:06:38
On Fri, 28 Dec 2001, Hubert Feyrer wrote:

> On Thu, 27 Dec 2001, David Brownlee wrote:
> > ap-auth-postgresql-1.2b2 DEPENDS errors:
> >         Version mismatch: 'postgresql' 6.5.3* vs 7.1.3
> >         Version mismatch: 'postgresql' 7.0* vs 7.1.3
> >
> > 	(The third entry in the DEPENDS list matches the current package)
> >
> > 	Should it just assume that if one entry matches the current package
> > 	then all is OK?
> No.
> If something wants 7.0* installed, and there is only 7.1.3, that is a
> problem that needs to be fixed. Presumably by testing if the new version
> still works with the package in question, then adjusting the depencency to
> >=7.0 or so.

	To clarify:

	The ap-auth-postgresql DEPENDS is postgresql-{6.5.3*,7.0*,lib-*}

	One of those entries (the last) matches the current version of
	postgresql in pkgsrc. The other two are to permit
	ap-auth-postgresql to be installed against earlier versions of
	postgresql. I do not see any reason to adjust the dependency
	until we want to drop support for installing on systems which
	have the older postgresql installed, and even if we do that it
	seems likely that _some_ package will have a similar DEPENDS.
		David/absolute		-- No hype required --